华为低端路由器配置脚本,三步到位

2019年10月25日10:57:19 发表评论 177 views

华为低端路由器配置脚本

根据本次工程特点:路由器本端由客户自己配置,我们只配通上行链路就可以了,如果这样

的话路由器只需以下三步简单配置就 OK 了:

1、配置路由器上行接口 IP 地址

2、配置路由器默认路由

3、保存配置

ping -c 1000 -s 5000 192.168.

以下是华为 AR2811 路由器配置为例( 版本,版本不一样命令有些差别)

首先用串口线通过 WIN XP 自带的超级终端或用第三方软件(如:SecureCRT)登录路由器

(波特率设置为:9600)

刚登录上路由器只在第一层使能模式,显示为“<”

要配置地址需要进入端口模式:[Quidway]interface [端口类型] [端口号]

要配置路由之类要进入配置模式,显示为“#”:>Quidway<system-view< p=""></system-view<>

1、配置路由器上行接口 IP 地址

>Quidway

[Quidway]

[Quidway]interface Serial 0/0 //进入端口模式(2M 上行口,不同版本的 2M 口配置不一

样,详见后面说明)

[Quidway-Serial0/0]ip address 172.36.30 255.255.255.252 //配置上行接口 IP 地址,具体

地址要看工单

[Quidway-Serial0/0]disp this //配置后可以用 disp thi 或 dis int serial 0/0 或 disp cu 命令

查看配置是否成功

[Quidway-Serial0/0]quit //退出接口模式

2、配置路由器默认路由

[Quidway]ip route-static 0.0.0.0 0.0.0.0 172.36.29 // 配置默认路由,目的地址用

0.0.0.0 0.0.0.0 表示,网关要看工单

[Quidway]quit

如果上层设备已配置好数据,可以在路由器上 ping 通网关地址了 ping 172.36.293、保存配置

>Quidway

The configuration will be written to the device.

Are you sure?[Y/N] //选 Y 回车就可以了

以下为可选取配置,根据客户需要选配

[Quidway]sysname LHAR2811 //给路由器命名,如罗湖 AR2811

[Quidway]super password level 3 cipher sz //设置路由器二级登录 SUPER 密码,需要维

护管理人员给出,如 SUPER 密码设置为:sz,

[Quidway]local-user huawei //创建登录用户名/密码,如用户名为:huawei

password cipher huawei //设置登录密码为:huawei

service-type telnet level 0 //设置登录访问级别,0 级为最低,3 级为最高,一般

登录就给 0 或 1 级就可以了

[Quidway]interface Ethernet0/0 //进入本地以太网端口模式

description to_LH //给端口添加描述

ip address 10.246.56.229 255.255.255.252 //配置 Ethernet0/0

如路由器接口下挂有交换机,而且交换机是要求配置 VLAN,则要进入该以太网的子接口

下配置,如 Ethernet 0/,配置 VLAN 100

[Quidway]interface Ethernet 0/

[Quidway-Ethernet0/]vlan-type dot1q vid 100 //配置子接口 VLAN 100

[Quidway-Ethernet0/]ip address 172.16. 255.255.255.0 //配置子接口 IP 地址,用于终

结 VLAN 100

以下是常见的 2M 接口配置,不同版本的路由器配置有些不一样,配置时只要跟传输端一

至就可以了

interface Serial0/0 //最简单一种,连时隙都不需要配置

description to_SZ //添加描述

clock DTECLK1 //端口默认时钟已是 DTECLK1

link-protocol ppp //端口默认协议已是 ppp

ip address 192.168.0.1 255.255.255.252 ////配置地址interface Serial1/0 //不分时隙的 2M 配置,需要配置端口为 unframed 模式

link-protocol ppp //端口默认协议已是 ppp

fe1 unframed //配置端口为 unframed 模式,即不分 2M 时隙

description to_HZNE08 //添加描述

ip address 172.32.16.1 255.255.255.252 //配置地址

interface Serial1/1 //分 2M 时隙配置

fe1 frame-format crc4 //配置 CRC4 模式

link-protocol ppp //配置链路协议

fe1 timeslot-list 1-31 //配置 2M 时隙

description to GouJi_DCN_HK1 //添加描述

ip address 132.127.148.113 255.255.255.252 //配置 IP 地址

ip route-static 0.0.0.0 0.0.0.0 10.246.56.5 preference 60 ////配置默认路由

user-interface vty 0 4 进入登录 VTY 模式,如果要远程管理一定要配置

authentication-mode scheme //配置登录认证为需要用户名和密码认证

>Quidway

删除配置命令:

华为设备的删除命令为 undo 开头,如删除地址为:undo ip add,删除路由为:undo ip

route-static 0.0.0.0 0.0.0.0 10.246.56.5

删除子接口为:[Quidway]undo interface Ethernet 0/

常用查看命令:

disp cu 查看所有配置数据

disp dev 查看硬件情况

disp int Ethernet 0/0 查看端口状态

disp thi 查看当前配置

disp ip route 查看 IP 路由

华为交换机配置要点

1、创建登录用户名和密码

2、创建 VLAN ID3、配置 IP 地址 (注意:一般交换机都是在 VLAN 下配置 IP 地址,路由器则是在端口下配

置 IP 地址)

4、设置端口模式(trunk、access、hybrid)

5、把 VLAN 把入具体端口

6、配置缺省路由

刚登录上交换机只在第一层使能模式,显示为“<”

要配置地址需要进入 VLAN 模式:[Quidway]interface vlan [vlan 号]

要配置交换机要进入配置模式,显示为“#”:>Quidway<system-view< p=""></system-view<>

local-user huawei //设置登录用户名

password cipher huawei //设置登录密码

service-type telnet //设置登录服务方式

level 3 //设置访问级别

vlan 100 //创建 VLAN 100

vlan 401 ////创建 VLAN 401

interface Vlan-interface401 //进入 VLAN 401,用于配置 IP 地址

ip address 172.16.71.35 255.255.255.0 //配置 IP 地址

interface Ethernet1/0/0 //进入以太网端口

port link-type access //设置该端口为 access 模式,用于接 PC 之类

port access vlan 100 //把端口加入到 VLAN 100 中

interface GigabitEthernet1/0/1 //进入以太网端口

port link-type trunk //设置该端口为 trunk 模式,用于透传 VLAN,一般用于上行

口或级联端口

undo port trunk permit vlan 1 //禁止 VLAN 1 通过该端口,为了防止环路产生,一般都

要禁止 VLAN 1 通过,因默认 VLAN 1 都是允许通过的

port trunk permit vlan 401 //设置允许通过的 VLAN

user-interface vty 0 4 //进入远程登录 VTY 模式

authentication-mode scheme //设置登录所采用的认证方式

ip route-static 0.0.0.0 0.0.0.0 172.16.7 //配置缺省路由

save //保存配置以下是几种常见组图配置脚本

语音业务:

一、路由器采用一个 2M 上行(也就是说移动提供一个 2M),路由器一个 FE 以太网端口连

接客户。

配置如下:

>Quidway

[Quidway]

1、配置端口 IP 地址

[Quidway]interface Serial 0/0 //进入端口模式(2M 上行口,连接移动端)

[Quidway-Serial0/0]fe1 timeslot-list 1-31 //配置 2M 时隙,一般端口默认是分时隙的,如果

端口已有该条命令就不用再配置了

[Quidway-Serial0/0]ip address 172.36.30 255.255.255.252 //配置上行接口 IP 地址,具体

地址要看工单

[Quidway-Serial0/0]disp this //配置后可以用 disp thi 或 dis int serial 0/0 或 disp cu 命令

查看配置是否成功

[Quidway-Serial0/0]quit //退出接口模式

[Quidway]interface Ethernet0/0 //进入以太网端口模式(该端口连接客户端)

[Quidway]ip address 10.246.56.229 255.255.255.252 //配置客户端口 IP 地址

[Quidway]quit

2、配置路由器默认路由

[Quidway]ip route-static 0.0.0.0 0.0.0.0 172.36.29 // 配置默认路由,目的地址用

0.0.0.0 0.0.0.0 表示,网关要看工单

[Quidway]quit

如果上层设备已配置好数据,可以在路由器上 ping 通网关地址了 ping 172.36.29

3、保存配置

>Quidway

Are you sure?[Y/N] //选 Y 回车就可以了

二、路由器采用 2 个 2M 捆绑上行(也就是说移动提供 2 个 2M),路由器一个 FE 以太网端

口连接客户。

配置如下:

>Quidway

[Quidway]

1、配置 IP 地址

[Quidway]interface Mp-group 1 //创建一个 2M 组 group 组 1,还有一种方法是

通过虚模板来创建 2M 组的,见后面部分

ip address 172.36.30 255.255.255.252 //配置上行接口 IP 地址,2M 捆绑地址

是在 group 里配置

quit

[Quidway]interface Serial 0/0 //进入端口模式(2M 上行口,连接移动端)

[Quidway-Serial0/0]fe1 timeslot-list 1-31 //配置 2M 时隙,一般端口默认是分时隙的,如果

端口已有该条命令就不用再配置了

[Quidway-Serial0/0]ppp mp Mp-group 1 //把该端口加入到 group 组 1

[Quidway-Serial0/0]disp this //配置后可以用 disp thi 或 dis int serial 0/0 或 disp cu 命令

查看配置是否成功

[Quidway-Serial0/0]quit //退出接口模式

[Quidway]interface Serial 0/1 //进入端口模式(2M 上行口,连接移动端)

[Quidway-Serial0/1]fe1 timeslot-list 1-31 //配置 2M 时隙,一般端口默认是分时隙的,如果

端口已有该条命令就不用再配置了

[Quidway-Serial0/1]ppp mp Mp-group 1 //把该端口加入到 group 组 1,这样 2 个 2M 都加

进了 group 组 1 了,加起来就是 4M 带宽了

[Quidway-Serial0/1]disp this //配置后可以用 disp thi 或 dis int serial 0/1 或 disp cu 命令

查看配置是否成功

[Quidway-Serial0/1]quit

[Quidway]interface Ethernet0/0 //进入以太网端口模式(该端口连接客户端)

[Quidway]ip address 10.246.56.229 255.255.255.252 //配置客户端口 IP 地址

[Quidway]quit2、配置路由器默认路由

[Quidway]ip route-static 0.0.0.0 0.0.0.0 172.36.29 // 配置默认路由,目的地址用

0.0.0.0 0.0.0.0 表示,网关要看工单

[Quidway]quit

如果上层设备已配置好数据,可以在路由器上 ping 通网关地址了 ping 172.36.29

3、保存配置

>Quidway

The configuration will be written to the device.

Are you sure?[Y/N] //选 Y 回车就可以了

*******

下面是通过虚模板 Virtual-Template 来创建 2M 组,和通过组来创建配置一样,只是把

Mp-group 改成 Virtual-Template 就可以了,其他配置不变

//

interface Virtual-Template 1 //创建 2M 虚模板 1

ip address 172.36.30 255.255.255.252

interface Serial0/0

link-protocol ppp

ppp mp Virtual-Template 1 //把端口加到虚模板 1 中

fe1 timeslot-list 1-31

interface Serial1/0

link-protocol ppp

ppp mp Virtual-Template 1 //把端口加到虚模板 1 中

fe1 timeslot-list 1-31

//

*******

数据业务部分

一:假设路由器采用一个 FE 端口做上行口,另一个 FE 连接客户设备,客户申请一个公网

IP 地址,要求内部 PC 通过路由器实现 NAT 地址转换上网。 公 网 IP 为 : 64.1.2/30 , 网 关 为 : 64. ; 内 部 PC 所 在 的 网 段 为 :

,内部网关为:192.168.。

配置如下:

>Quidway

[Quidway]

1、配置端口 IP 地址

[Quidway]interface Ethernet0/0 //进入端口模式(FE 上行口,连接移动端)

[Quidway-Ethernet0/0]ip address 64.1.2 255.255.255.252 //配置上行接口 IP 地址,具体

地址要看工单

[Quidway-Ethernet0/0]disp this //配置后可以用 disp thi 或 dis int Ethernet 0/0 或 disp cu

命令查看配置是否成功

[Quidway-Ethernet0/0]quit //退出接口模式

[Quidway]interface Ethernet0/1 //进入以太网端口模式(该端口连接客户端)

[Quidway]ip address 192.168. 255.255.255.0 //配置客户端口 IP 地址

[Quidway]quit

2、配置路由器默认路由

[Quidway]ip route-static 0.0.0.0 0.0.0.0 64. //配置默认路由,目的地址用 0.0.0.0

0.0.0.0 表示,网关要看工单

[Quidway]quit

如果上层设备已配置好数据,可以在路由器上 ping 通网关地址了 ping 64.

3、NAT 地址转换配置

[Quidway] nat address-group 10 64.1.2 64.1.2 //配置公网地址池

[Quidway] acl number 2000 //配置 ACL 访问列表,也就是允许那些地址

可以转换出去

rule 0 permit source 192.168.1.0 0.0.0.255 //配置私网地址段,注意是反掩码

[Quidway]interface Ethernet0/0 //进入上行口

nat outbound 2000 address-group 10 //配置私网地址段与公网地址相关联

4、保存配置

>Quidway

The configuration will be written to the device.

Are you sure?[Y/N] //选 Y 回车就可以了二:假设路由器采用一个 FE 端口做上行口,另一个 FE 连接客户设备,客户申请二个公网

IP 地址,一个公网 IP 用于内部 WWW 服务器,一个用于内部 PC 上网。

要求在公网可以访问到公司 WWW 服务器和内部 PC 通过路由器实现 NAT 地址转换上

网。

公 网 IP 为 : 64.1.2-3/29 , 网 关 为 : 64. ; 内 部 PC 所 在 的 网 段 为 :

,WWW 内部服务器地址为:192.168.00,内部网关为:192.168.。

配置如下:

>Quidway

[Quidway]

1、配置端口 IP 地址

[Quidway]interface Ethernet0/0 //进入端口模式(FE 上行口,连接移动端)

[Quidway-Ethernet0/0]ip address 64.1.2 255.255.255.248 //配置上行接口 IP 地址,具体

地址要看工单

[Quidway-Ethernet0/0]disp this //配置后可以用 disp thi 或 dis int Ethernet 0/0 或 disp cu

命令查看配置是否成功

[Quidway-Ethernet0/0]quit //退出接口模式

[Quidway]interface Ethernet0/1 //进入以太网端口模式(该端口连接客户端)

[Quidway]ip address 192.168. 255.255.255.0 //配置客户端口 IP 地址

[Quidway]quit

2、配置路由器默认路由

[Quidway]ip route-static 0.0.0.0 0.0.0.0 64. //配置默认路由,目的地址用 0.0.0.0

0.0.0.0 表示,网关要看工单

[Quidway]quit

如果上层设备已配置好数据,可以在路由器上 ping 通网关地址了 ping 64.

3、NAT 地址转换配置

[Quidway] nat address-group 10 64.1.2 64.1.3 //配置公网地址池,公网地址池要把内

部服务器所对应的公网 IP 也包括在内

[Quidway] acl number 2000 //配置 ACL 访问列表,也就是允许那些地址

可以转换出去rule 0 permit source 192.168.1.0 0.0.0.255 //配置私网地址段,注意是反掩码

[Quidway]interface Ethernet0/0 //进入上行口

nat outbound 2000 address-group 10 //配置私网地址段与公网地址相关联

nat server protocol tcp global inside 192.168.00 www //配置公司

WWW 服务器与公网地址 关联

4、保存配置

>Quidway

The configuration will be written to the device.

Are you sure?[Y/N] //选 Y 回车就可以了

三:假设路由器采用一个 FE 端口做上行口,另一个 FE 连接客户设备,客户申请一个公网

IP 地址,要求内部 PC 通过 DCHP 自动获得 IP 地址上网。

公网 IP 为:64.1.2/30 ,网关为:64.;内部 PC 所在的网段为:。

配置如下:

>Quidway

[Quidway]

1、配置端口 IP 地址

[Quidway]interface Ethernet0/0 //进入端口模式(FE 上行口,连接移动端)

[Quidway-Ethernet0/0]ip address 64.1.2 255.255.255.252 //配置上行接口 IP 地址,具体

地址要看工单

[Quidway-Ethernet0/0]disp this //配置后可以用 disp thi 或 dis int Ethernet 0/0 或 disp cu

命令查看配置是否成功

[Quidway-Ethernet0/0]quit //退出接口模式

[Quidway]interface Ethernet0/1 //进入以太网端口模式(该端口连接客户端)

[Quidway]ip address 192.168. 255.255.255.0 //配置客户端口 IP 地址

[Quidway]quit

2、配置路由器默认路由

[Quidway]ip route-static 0.0.0.0 0.0.0.0 64. //配置默认路由,目的地址用 0.0.0.0

0.0.0.0 表示,网关要看工单

[Quidway]quit 如果上层设备已配置好数据,可以在路由器上 ping 通网关地址了 ping 64.

3、NAT 地址转换配置

[Quidway] nat address-group 10 64.1.2 64.1.2 //配置公网地址池

[Quidway] acl number 2000 //配置 ACL 访问列表,也就是允许那些地址

可以转换出去

rule 0 permit source 192.168.1.0 0.0.0.255 //配置私网地址段,注意是反掩码

[Quidway]interface Ethernet0/0 //进入上行口

nat outbound 2000 address-group 10 //配置私网地址段与公网地址相关联

quit

4、配置 DHCP

[Quidway] dhcp server ip-pool 1 //配置 DHCP 自动分配地址池

network 192.168.1.0 mask 255.255.255.0 //配置自动分配的地址范围

gateway-list 192.168. //配置 192.168. 为网关地址

dns-list 2136.192.6 2139.163.6 //配置 DNS 地址,一般配置 2 个,以

防一个出现故障另一个可以备用

quit

[Quidway]dhcp select global interface Ethernet 0/0 //配置需要运行 DHCP 自动分配 IP 在端

口,一般是连接客户的端口

[Quidway]dhcp server forbidden-ip 192.168. //配置网关地址不参与地址分配

5、保存配置

>Quidway

The configuration will be written to the device.

Are you sure?[Y/N] //选 Y 回车就可以了

******************

移动 DNS 地址为:2136.192.6 2139.163.6

电信 DNS 地址为:202.96.128.86 202.96.134.133

******************四:假设路由器采用 2 个 2M 捆绑做上行口,一个 FE 连接客户设备,客户申请一个公网 IP

地址,要求内部 PC 通过路由器实现 NAT 地址转换上网。

公 网 IP 为 : 64.1.2/30 , 网 关 为 : 64. ; 内 部 PC 所 在 的 网 段 为 :

,内部网关为:192.168.。

配置如下:

>Quidway

[Quidway]

1、创建 2M 组用来配置 IP 地址

[Quidway]interface Mp-group 1 //创建一个 2M 组 group 组 1,还有一种方法是

通过虚模板来创建 2M 组的,见后面部分

ip address 64.1.2 255.255.255.252 //配置上行接口 IP 地址,2M 捆绑地址是

在 group 里配置

quit

2、把端口加入到 2M 组中

[Quidway]interface Serial 0/0 //进入端口模式(2M 上行口,连接移动端)

[Quidway-Serial0/0]fe1 timeslot-list 1-31 //配置 2M 时隙,一般端口默认是分时隙的,如果

端口已有该条命令就不用再配置了

[Quidway-Serial0/0]ppp mp Mp-group 1 //把该端口加入到 group 组 1

[Quidway-Serial0/0]disp this //配置后可以用 disp thi 或 dis int serial 0/0 或 disp cu 命令

查看配置是否成功

[Quidway-Serial0/0]quit //退出接口模式

[Quidway]interface Serial 0/1 //进入端口模式(2M 上行口,连接移动端)

[Quidway-Serial0/1]fe1 timeslot-list 1-31 //配置 2M 时隙,一般端口默认是分时隙的,如果

端口已有该条命令就不用再配置了

[Quidway-Serial0/1]ppp mp Mp-group 1 //把该端口加入到 group 组 1,这样 2 个 2M 都加

进了 group 组 1 了,加起来就是 4M 带宽了

[Quidway-Serial0/1]disp this //配置后可以用 disp thi 或 dis int serial 0/1 或 disp cu 命令

查看配置是否成功

[Quidway-Serial0/1]quit

[Quidway]interface Ethernet0/1 //进入以太网端口模式(该端口连接客户端)

[Quidway]ip address 192.168. 255.255.255.0 //配置客户端口 IP 地址

[Quidway]quit3、配置路由器默认路由

[Quidway]ip route-static 0.0.0.0 0.0.0.0 64. //配置默认路由,目的地址用 0.0.0.0

0.0.0.0 表示,网关要看工单

[Quidway]quit

如果上层设备已配置好数据,可以在路由器上 ping 通网关地址了 ping 64.

4、NAT 地址转换配置

[Quidway] nat address-group 10 64.1.2 64.1.2 //配置公网地址池

[Quidway] acl number 2000 //配置 ACL 访问列表,也就是允许那些地址

可以转换出去

rule 0 permit source 192.168.1.0 0.0.0.255 //配置私网地址段,注意是反掩码

[Quidway]interface Mp-group 1 //进入 2M 组 1,注意 2M 捆绑 NAT 相联是在

组下面,不是在端口下

nat outbound 2000 address-group 10 //配置私网地址段与公网地址相关联

5、保存配置

>Quidway

The configuration will be written to the device.

Are you sure?[Y/N] //选 Y 回车就可以了

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: